Degraded service for MDW ingest and playback
Incident Report for Livepeer Studio
Postmortem

What Happened

On 7/31/21 from 10:28 UTC to 11:22 UTC MDW region ingest and playback was down or intermittent. During this time, users whose nearest datacenter was MDW, or who had chosen to stream into MDW, would have needed to manually reroute their streams to an alternative datacenter in order to successfully stream.

What We Are Doing About This

Although a precise root cause has not been identified, the team believes that the incident was related to our DNS. We’re currently working on changes that would increase resiliency of our systems should this issue happen in the future, including addressing single points of failures and increasing observability.

Posted Aug 11, 2021 - 20:42 UTC

Resolved
This incident has been resolved.
Posted Jul 31, 2021 - 11:22 UTC
Monitoring
We have taken MDW out of global ingest/playback rotation, and are monitoring the situation. Streams sent to global ingest/cdn should be re-routed automatically now.
Posted Jul 31, 2021 - 11:15 UTC
Update
The ingest works, but the playback is intermittent. We are continuing to investigate the issue. As a workaround, redirect new streams to LAX or NYC.
Posted Jul 31, 2021 - 10:41 UTC
Investigating
We have received and confirmed reports that ingest and playback in MDW is down. As a workaround, redirect new streams to another Livepeer.com ingest datacenter.

If you're currently experiencing this issue or need additional assistance, please reach out to help@livepeer.com.
Posted Jul 31, 2021 - 10:28 UTC
This incident affected: Livepeer Streaming API and Livepeer Studio Ingest and Playback (Chicago (MDW) ingest and playback).